Roborock s5 max not connecting to the network

Roborock s5 max not connecting to the network

Hi, i have been having a problem with my s5max. It doesnt want to let me connect to the network. I tried both the roborock and mi home apps. It still didnt work well

Is there any suggestion? What should i do?

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hello,

    We can use Roborock app do some troubleshooting first.

    1. Make sure the wifi password you've input is correct.

    2. Don't use an android tablet, iPad, iPhone 5 or iPhone 5C to connect the robot as there might be compatibility issues.

    3. Enable location permission like in attached picture. If it is iOS 14.0, please enable "local network" permission for it as well.

    4. Pay more attention to the select wifi step. See attached picture "select your home wifi".

    5. If there are special characters like !@#$ contained in your wifi name or password it is suggested that you log in to the router and remove them in the wifi settings.

    6. The robot doesn't support WEP encryption mode. If your wifi is WEP, change it to WPA or WPA2.

    7. If you understand the router's setting well then change DNS to in the router's settings page.

    8. Reboot your router, your robot and try again.

    Also, you can connect it to the mobile hotspot.

    You must get 2 smart phones( A and B) .

    1. Enable phone A's hotspot in phone's setting and create a name and password of hotspot.

    2. Use phone B to install app and try to make robot cleaner connect hotspot sent from phone A.

    Forget about the wifi from router in the whole process.

    rdog02/22/2021      01:47

    Same issue for me. The roborock s5 max was working well for 7 months, but as of last week, I'm having this same issue. Nothing has changed - it just stopped connecting for some reason. Any further tips? I have tried most of these things.

    RR_SupportStaff Member02/22/2021      09:26

    Hi, have you tried connecting the device to a hotspot? Can it be connected to a hotspot?


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum