Roborock S5 - white light of death

Roborock S5 - white light of death

Hi, the On/Off Button started blinking very fast with red light while my Roborock S55 ws in the dock. Once I tried to turn it off it started blinking again very fast but this time with white light. I tried again to turn it off – but no effect; I pressed Reset button – no effect; then I tried reset to factory default – it stopped blinking for 3-5 sec and then again it started blinking white. Note - there was no voice prompt from the speaker; Wi-Fi indicator light is off and device does not have connection with MI Home App. Now the On/Off button is just blinking fast over-and-over. Any clue?

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Dear customer,

    For the dock charger, could you send us a video of this abnormal behavior? It is suggested to upload the video online like google drive and send us the video link if the video is large. (remember add our address to list to access video)

    You need to use your biggest strength to press the cable head into the bottom of slot and ensure that the dock and the robot are connected firmly.

    As for the wifi led, try to turn on the S5 first by pressing the power button, and you can reset it to verify whether it turns to flashing blue.

    Step 1. Hold the recharge button for 3-5 seconds.

    Step 2. Use a pin to press the reset button next to wifi LED just once,and power button, recharge and spot cleaning button's light will be out. When you are doing this, please make sure recharge button is still under your finger's holding without moving.

    Step 3. Keep holding recharge button for 5 seconds after you press reset button until power button blinks again and you hear the tone "Restoring the initial version. It will take about five minutes. Please wait patient", and then you could remove the finger.


    1. Factory default restore will disconnect RoboVac from wifi. Please re-add it after factory default restore.

    2. Factory default restore will also make RoboVac's firmware version come back to original one when it was made in factory. After factory default restore, you could go to RoboVac's setting--general setting--check for updates to upgrade its firmware to latest one.

    3. Factory default restore will delete all your setting on device like scheduled cleaning.

    4. Factory default restore will delete every single cleaning's log including every cleaning's duration, size and map. But the total duration, total times of cleaning and total size will be still kept there.

    Could you tell us your device's SN?

    Open the cover of device and take out the dustbin. You will see a bar code on device's bottom(not on dust bin). The SN is under bar code like R0201S82418800.

    Could you send us purchase info?

    Pls send us the purchase link(or screen of product listing), and invoice or receipt (file or screenshot) which shows seller's name, purchasing date and order number.

    Dom05/21/2020      14:51


    Product Model: S552-00

    Serial Number (found under dust bin): R0019S94303292

    Purchased on AliExpress the Seller: Superlative Store

    Order Number: 3002808354955429

    Order Date: Jan 26, 2020 19:05

    The dock charger looks fine in general. I just mentioned about the dock as the problem started once the robot was charging in th dock. I did restore to factory default step by step as you described but it does not completed correctly. In Step 3. nothing happens i.e. there is no tone "Restoring the...". The Power button just starts blinking again and that is it.

    RR_SupportStaff Member05/22/2020      07:58

    Hi, thanks for your updates.

    It seems that there is something wrong about the device.

    Under such circumstances, we suggest you contact seller for warranty service. As the manufacturer, we could provide customer technical support and seller is responsible for warranty. It is because we have agreement with our first class official distributors when we sell devices to them that warranty of product is provided by sellers. We appreciate your understanding.

    Dom05/28/2020      13:56


    Unfortunately the AliExpress seller, the SuperlativeStore is not responding and seems they have just ignored our case.... no contact from them so far.... not sure what to do next.

    Load More >>

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum