Unable to connect to device wifi

Unable to connect to device wifi

I purchased a  new Q Revo earlier in the week - its a great unit but having a problem with it. 

I initially had it set up with the MiHome app but wanted to use the Roborock app for the better scheduling/routine functions. 

I reset the wifi of the vacuum to swap it over but the Q Revo is not broadcasting the roborock-vacuum-"ABC123" wifi network. 

Roborock support are not helpful at all - I'm still trying to figure out if I'm communicating with a bad AI. 

I thought given the activity in this community someone may have found a solution that doesn't involve more pain with Roborock support.

This has nothing to do with 2.4ghz wifi and putting my phone on airplane mode etc. 

This is to do with step 1 where you connect to the vacuum's wifi and then pair it with your home network. 

So far I have:

Reset the wifi on the vacuum multiple times.
Factory reset the vacuum
Forgotten the wifi network on my phone.
Tried with an ipad, another iphone, an android phone and my Mac - safe to say the network is not broadcasting.
Turned the vacuum off, back on, fully charged it and then reset the wifi.

The blue wifi light on the vacuum flashes when I reset it other times it remains off. 

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Turn off cellular on your phone or have it on airplane mode before you try to pair

  • Hello, thanks for reaching out. The wifi light should be flashing blue when you reset wifi. But now it's always off, which is abnormal. The issue you faced may not be solved in a short answer. We hope we could work with you to locate the cause and address it. Would you please contact us at support@roborock.com(if you are in EU, contact support@roborock-eu.com)so that we can better assist?

  • hi, did this issue got resolved?

    I am facing same issue, right now Roborock is going to replace my vacuum. But I want to know root cause of this issue.

    Robotics device WiFi is now showing up in available WiFi networks list after doing robot WiFi reset. ( I made sure, that none of my devices have this robot WiFi network saved. Did network reset on my phone )

    issue is not with 2.4G or 5G WiFi network with my router. Even if I don’t have any router at home, when I do WiFi reset on robot, it should show WiFi connection in available networks list.

    Vicky06/02/2024      20:14

    I am using Q5 pro


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum