Firmware Update Problem

Firmware Update Problem

Hi !

I have updated firmware to version 01.49.66 for S6 MaxV and have some problems.

The device only works for a few minutes and then sends a trapped notification.

The device sometimes moves in a circle pattern, move slow and messy, although no obstructions have been detected.

This issue happens very often after an update.

I cleaned the sensors, removed the water tank, removed the rag, cleaned the main brush, the secondary brush, manually restarted it but failed to fix the problem.

I'm sure the device hasn't had any physical damage and has worked fine with the old firmware - 01.46.00

Please show me how to revert to the previous firmware.


You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hello,

    We can do some troubleshooting first.

    1. Go to cleaning history and send us some problematic cleanup maps.
    pth.tn10/20/2020      07:02

    This is the picture when encountering problems

    pth.tn10/20/2020      07:05

    This is the picture when there is no error

    RR_SupportStaff Member10/20/2020      10:09


    Thanks for your reply and info.

    Is mopping system installed when this issue happens?

    Uninstall the mopping mount and mopping cloth to have a try.

    Also, you can send us some pictures of the water tank and mopping cloth.

    Load More >>
  • I updated to firmware 01.49.66 and got the same error, but when I removed the water from the robot and didn't get the same error. Everyone on the Facebook group also complained about the above error and demanded to run Roborock s6 maxv

    RR_SupportStaff Member10/22/2020      11:02
  • @RR_Support:

    I saw another post on the forum and you showed how to be able to restore the previous firmware version - 01.46.00. I have tried and succeeded. Those experiencing the same problem can try this method, but will need to reconnect the robot to the application and reinstall from scratch. Here's a factory reset for the robot, I ask permission to repost it.

    Step 1. Hold the top up button for 3-5 seconds.

    Step 2. Still keep the recharge button not moving and press the reset button next to the wifi LED with a single pin. The power and charge button lights will then turn off.

    Step 3. Keep holding the recharge button for 5 seconds after you have pressed the reset button until the power button light flashes again, then you will hear the sound "Restore original version. It will be lost. about five minutes. Please wait patiently. ”After that, you can stop holding the top up button.

    Step 4. Reconnect the robot to the application and and reinstall from scratch.

    I see in the new firmware update - 01.49.66, it is possible to name the rooms. That's great.

    Hopefully the technical team can fix the problems during this testing to roll out the most complete update to

    RR_SupportStaff Member10/23/2020      09:55

    Glad to hear that you figured it out. And we have forwarded this issue to our RD team and we will work on it.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!
Welcome to Roborock Forum