Roborock S50, unable to upgrade to a newer firmware version again (3.5.7_002008)

Roborock S50, unable to upgrade to a newer firmware version again (3.5.7_002008)

After the purchase, the Roborock S50 was updated to the 3.5.7_002008 firmware and it worked for about 10 months. One night I heard it goes back to the firmware backup. At the moment Robo is working on version 3.3.9_001886 and there is no way to update it to version 3.5.7_002008. A request for support and help.

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Do you see a new firmware available on the app?

    If you did see the new firmware, did it fail on downloading the firmware or installing it?

    You can send us a screenshot for reference.

    elkaszokus01/13/2021      13:48

    The update is visible, it is being downloaded. The robot communicates "Updating firmware, it will take 5 - 10 minutes." After a few minutes it says "Couldn't update firmware. Switch to previous version." I did a factory reset, still the same.

    RR_SupportStaff Member01/14/2021      09:03

    Pls make sure your robot is on dock and the battery is more than 20% when you try to upgrade its firmware version. If upgrading failed, try methods below:

    1. Check if there is new version of Mi Home app in google play or app store. You can uninstall and reinstall the APP also.

    2. Move robot close to router and test again.

    3. Move robot away from dock and reboot it by pressing and holding power button.

    4. Switch region of app and add robot to app again to test. See attached picture how you can switch region(you need re-add robot to app when region is switched). 

    5. Change the primary/secondary DNS server on the main router to

    6. Besides, you can connect the robot to the mobile hotspot to give it a shot. 

    You must get 2 smart phones( A and B) .

    1. Enable phone A's hotspot in phone's setting and create a name and password of hotspot.

    2. Use phone B to install app and try to make robot cleaner connect hotspot sent from phone A.

    Forget about the wifi from router in the whole process.

    elkaszokus01/14/2021      12:57

    I have completed steps 1, 2, 3, 4, 6. Still unchanged.

    Can you check any update logs on the server if I provide the profile number?

    Load More >>

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum