Roborock S5 navigation issue after 3.5.8_002034 firmware update

Roborock S5 navigation issue after 3.5.8_002034 firmware update


I have used my Roborock one year now. There has been few FW updates already and I have not faced any issues with them. Now with latest update to version 3.5.8_002034 I have faced issue with navigation. Roborock seem to randomily vacuum only some areas of house or of certain room. I tried to reset the map by disabling and enabling "Map saved mode (Beta)" from Vacuum settings in app, but it did not have any impact. Here's couple screenshots from app when full house is tried to vacuum, but without success.

What should I do to get my Roborock work as it was before FW update?

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hi,


    Thanks for your feedback.

    I. May I suggest you move the dock to the central area of your house to have a try?

    The space for the dock should be no less than 0.5 m wide on the left and right side, and 1.5 m wide in front of it.

    II. Then pls reset the map and create a new one.

    III. Please use a piece of cloth the clean the wall sensor at right of device

    like attached picture to have a try. If problem still exists, could you please send us a picture of wall sensor? You need to open the flash when taking photo of wall sensor so that it could show inside of sensor clearly.


  • I reply to my self, issue is solved. This is just FYI for others who may have same problems.

    Key word is "wet cloth"! I already clean all the sensors yesterday with dry cloth and sensors were clean, however today I noticed that after yesterday trials they were totally covered by dust. Now I used wet cloth and sensors stayed clean. Might be that sensors plastics were electrostatic charged due to very dry relative humidity (<25%) in my house and it gather all dust to it, but after wet close it might discharge electrostatic charge from plastic..

    Anyway impact was huge and I did nothing else for Roborock than just clean sensors with wet cloth.

    RR_SupportStaff Member02/02/2021      12:22

    Hi, it seems the issue is caused by the dust on the wall sensor. 😃 Glad to hear that! Good day!


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum