Roborock S5 Max Navigation Issue

Roborock S5 Max Navigation Issue

Hey there, I've been having trouble with my robot firmware version 3.5.8.1328

The problem had happened before the update, but the problem has become worse and i needed some help and input

2 days ago (6 Feb), the cleaning path was okay (image 1)

But then, on 7 Feb it suddenly turned more erratic and today was even worse


I read some of the forum posts and found some suggestions of removing the mopping pads and so i did, for now i can only do 1 sweep in a smaller room without mopping pads and compare it to the history on 6 feb (with mopping pads). The result shows a much better pathing and time.


So a this point, what should i do to fix this?

Some more details:

  1. The water level was set on low, medium on the smaller room in the example above
  2. there's a noticeable 'wetness' on the plastic that hold the mopping pad, sometimes i can see a small puddle forming on the floor
  3. The bot go around non-existent things, all hard floors for the examples above and no black tiles


You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hi,

    Thanks for your updates. Have you tried setting water level to medium or low in other rooms?

    We've updated the water release strategy. It's possible the water level that used to be release just enough water now releases more than needed, and therefore, the robot slipped.

    We suggest you lower the water level to medium or low for the entire house to have a try,

    Like0
    Arcwindz
    Arcwindz02/08/2021      09:30
    @RR_Support:

    Like i mentioned above, the water level was set on low in the place that has a significant error (the big room). It's been working well for more than half a year with those settings and there has been no changes between 6 Feb cleaning and today.

    There's another result from a room with the same tile as the 2nd (smaller) room, i used the low water setting there and it still shows erratic behavior nonetheless. So no, i don't think changing water level can help me in solving this problem.

    Another post (https://forum.roborock.com/discussion/2515/roborock-s5-max-map-and-navigation-issue/p1) has a similar issues to mine and a user has been getting a response from your team regarding applying a waterproof coating on the groove around the water exit holes.

    Can i inquire on the exact procedures for this quick fix? Of course we need a firmware support in the near future. As i see it, this has been happening a lot more often after the "increased waterflow" update, first it happened on the room with higher waterflow and now it affect even the one with lowest waterflow setting.

    I have only come here for support after the robot decided to take 40% more cleaning time than usual (and not even finish cleaning the whole room).

    Like0
    Iswan
    Iswan02/10/2021      17:06
    @Arcwindz:

    It seems that the problem with the rubber wheels is becoming slippery because the surface of the wheel runs over water too often. I tried rubbing the surface/tread of the wheels with sandpaper so that the surface of the wheels became rough, the results were good, there were no more erratic paths, even with a medium water level there were no more problems, however  Haven’t tried yet with high water level. The rougher the wheel tread the better to avoid slipping. When scrubbing the wheels, make sure wheels position are under the machine otherwise the rubbing dirt may fall into the robot machine. 

    Every time I use the robot, rubber wheel is scrubbed, with a cycle of 1 time with sandpaper and 3 times with a dry mop (I use a dry robot's mop). Hope this is useful for you guys.

    I am now ordering anti slip wheel cover, but was not arrived yet. I assume by using the same, no need scrubbing the rubber wheel anymore (see photo).

    Like1
    Arcwindz
    Arcwindz02/21/2021      08:08
    @Iswan:

    Hey, I just got my rubber yesterday and it worked really well, the time needed to clean the room has improved significantly

    I still have a problem with docking where the robot refused to dock at times before eventually stopping near the dock, but so far the time needed with and without mop is almost the same (low water level)

    Thanks for the input friend!



    Like0
    Load More >>
  • Just another update, after managing to get rid of the problem for several days, i decided to increase the water level to see the result.

    Well, it's not good

    On a marble floor, medium mess everything up and on a tile floor, medium is still okay albeit with some errors while high is just unmanageable.

    The worst part is that now even when changing the setting back to low on a marble floor, the robot is still making so much error. What has been a 90 min clean now came back to 120 min+.

    I don't know if it's the sensor or what, but i'll just update it here if this ever needed by Roborock team even if i'm quite disappointed with the support team... I mean, 1 unhelpful reply and no follow up? Really?

    Like0

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Arcwindz
Welcome to Roborock Forum