S7 Auto-Empty Dock Jammed

S7 Auto-Empty Dock Jammed

I've had my auto empty dock for a couple weeks. The first few times it ran, it did great - completely emptied the dust bin. Then I got a message saying the Auto Empty Dock was jammed. I turned the S7 over and sure enough, there was a big clump of hair (I have 2 dogs - a Bernese Mountain Dog and a Boxer) that I removed. Removed that clump and figured all would be good. Ran it the next day and got the same error, only this time it didn't even try to empty the bin and there was no clump under the S7. I looked at the chute under the dock and it's clear. I took the bag out and it's got plenty of room. I removed a little hair from the chute into the bag and tried it again - same error. I removed the filter and there was nothing on it. So now I'm guessing there is hair somewhere between the chute under the dock and before the bag.

So my question is, is there a way to remove the housing the filter sits in so I can clean around that? I don't know where else the clog could be. The S7 is clear from the bin to the roller, the bag has capacity left, there's nothing in the chute that I can feel at the bag inlet and the filter is clean so it has to be from the bottom up to the bag.

Any help is appreciated.

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Following

    RR_SupportStaff Member01/28/2022      10:37


    Thanks for reaching out.

    Would you please use a cotton swab to clear the dust-inlet on the auto-empty dock? See attached picture.

    REtopetp[09/29/2023      12:45

    What if it's the same problem, but there is something stuck in the airway that doesnt let us remove the dustbin from the autoclean dock first to acces the airway? How to remove the dustbin in this case?

    RR_SupportStaff Member11/26/2023      06:49

    Hello, thanks for reaching out. May I know if you've got the dirt out of the bin? You can lay the machine side down, with the bin on the floor. Then tap the other side a few times. This is to try to shake off the dirt that's stuck between the dirt inlet and the dustbin. If the issue persists, the device may need warranty service. would you please reach out to our support team at support@roborock.com(if you are in EU, contact support@roborock-eu.com) so that we can better assist?

    Load More >>

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum