S5max not connecting to wifi

S5max not connecting to wifi

I recently purchased a S5 max it was working perfil y fine until a few days now it doesn’t want to connect. I tried the riborock app and also mihome app and the same issue.

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Have the same problem. It worked fine for year, but now since yesterday I can't connect wifi and can't start robot. Tried reset wifi, tried official roborock app tried xiaomi app. Nothing works. What happened?

  • EDIT: I did a reset, by small button, then configured device

    RR_SupportStaff Member12/18/2021      15:02


    Thanks for your reaching out.

    We noticed the thread you shared with other in another article. The device now can not be turned on even by pressing the start button. Could you please check if the device can be powered on or not when you place it on the charging dock and charging?

  • Hello,

    Thank you for taking the time to reach out to Customer Support and we are sorry to hear about the trouble you are having with your device.

    Please reboot the robot and check whether it can reconnect to the home wifi successfully.

    Note: Move the robot off the dock, press the power button for 3-5 seconds to turn it off/on manually.

    If it is still the same, we suggest you delete the offline device and reconnect it.

    1. Press and hold the offline device on the app and then remove/delete it.

    2. After that, reconnect it to the home wifi.

    Best regards.

  • Same problem here. It disconnected from WIFI out of a sudden and would not reconnect.

    Tried all kind of possible solutions:

    • Rebooting - not working
    • Factory reset - not working
    • App location permissions added - not working
    • App cache cleaning - not working
    • App reinstall - not working
    • Trying iOS instead of Android phone - not working
    • Router reboot/reset - not working
    • Setting up router according to recommendations - not working
    • Connecting to different hotspot - not working

    Its seems that there is some kind of a hardware failure or there was a 'silent' update that messed thing up.

    What are the recommendations to get this fixed? Or should I just return it and get my money back?

    Was a really great product while it lasted. Now it lost like 70% of functionality and does not meet my needs.

    RR_SupportStaff Member12/27/2021      01:08


    Thank you for taking the time to reach out to Customer Support and we are sorry to hear about the trouble you are having with your device.

    There's another app called Mi home app. Would you please give it a try as well? See attached QRcode.

  • Please comment if anyone was able to solve this. I am having this issue since yesterday

  • Guys, I had this problem and the last suggestion made by roborock that said to try the mi home app worked pretty fine!

    But why this is happening is the great question! =/


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum