Roborock v1 navigation problems

Roborock v1 navigation problems

I'm experiencing a huge problem with my roborock v1 navigation system. I think it started a couple weeks after I replaced the main brush, and despite I don't believe there is a correlation with it, I thought it would help bringing to this post.

I already tried several fixing options like:

- factory reset

- deep cleaning cliff and wall sensors

- check if there was any occlusion on Lidar rotation

- changed dock station place to a more open space

- check if there was anything blocking some of the two wheels.

Nothing worked.

I first noticed when after a cleaning schedule the robot finished on a random place far from the dock, without telling there was a problem.

So I looked at the map and the path the robot made was completely random with no patterns. Now, every time I turn on, it keeps failing to navigate properly, doing some backwards movements really weird.

Attached there is an example of the map.

I have this model since 2018 and it is the first time I face an issue.

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hi thanks for reaching out.

    Your question may not be solved in a short answer. We suggest you contact us via email: You could attach related pictures or videos in email for further help.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Mi User-v1
Welcome to Roborock Forum