S4 offline in Roborock app

S4 offline in Roborock app


I have had the Roborock S4 for about two months and I use the roborock app. It was working fine but lately it keeps saying off-line. When I clicked under the robot it just shows loading a map and won’t load anything so I can’t even click on the icon to update firmware. The other day I played with it by using the plus button to add a new Robo rock and after about five times I finally got it to get online and then I exited back out and went into my robo rock map and it vacuumed. I was hoping that fixed it but today it’s off-line again and when I try to add a new roborock, it’ll connect to the Wi-Fi and connect the roborock to WiFi, but won’t do the third step and just fails. I tried multiple times and can’t get it to get online. What do I do?

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • We are sorry for the trouble you are facing and for all the inconvenience. 

    1. Could you please try to delete the S4 in app by long tapping the card as attached picture? And then to reset WiFi for S4.

    2. If by any chance, you are able to reconnect it, may we suggest you try to check if there is any firmware update available as attached picture.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum