can't connect Google Assistant to Roborock app anymore (S6)

can't connect Google Assistant to Roborock app anymore (S6)

hi, yesterday i noticed Google Assistant voice commands stopped controlling my S6 (sorry, I can't connect to your Roborock right now) .

I tried reconnecting the account, which didn't work. So I deleted the service and tried readding it -

every now and then, I get "wrong password" on the roborock oauth page ,

but after 2 tries with the exact same password, it manages to login but still doesn't add the Roborock service to Google Assistant.

Sometimes there's no error message, sometimes it gives me "unable to add service, check your network connection" .

I've tried so far, clearing the cache for the Roborock app, Google app, signing out of the Roborock app, but nothing helps.

Since GA was working fine with Roborock just a couple of days ago, is this a temporarily issue with your service?


You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Dear Customer,

    Sorry for all the inconvenience caused.

    Could you please try to connect it again? Our tech team checked the issue with Google, and found there is something wrong on the Google side server. Now the issue is fixed. Could you please try it again?

    anonyless05/03/2020      08:53

    thank you for the quick reply, i managed to add the service and it seems to be working okay

    Arda02/13/2021      12:49

    I believe same problem happened again and there is no solution, could you contact google

    rock2202/13/2021      20:39

    I'm having same issue with my S4 max. It was working on Google Home. Stop responding a few days ago. I can't reconnect or add it back to google home now.

    Load More >>

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum