frame

Issues since Firmware 01.07.80

Issues since Firmware 01.07.80

Hello - since updating to the new firmware 01.07.80 a few days ago I've had issues with the bot not knowing where the dock is after cleaning rooms. On several occasions now, on ad-hoc 'Room' clean, after the room cleaning is complete, instead of saying "room cleaning complete, going back to dock" the bot goes into another room to clean despite that room not being requested to be cleaned. This has happened several times and once after mopping the tiles in the kitchen the bot went into the living room, which is carpeted, with a wet dirty mop. It's done this several times now - basically, after a room clean I must now keep an eye out and manually return it to the dock through the ap. This works ok so the bot knows where the dock is and has no problem going there when i tell it, just not on it's own. This of course means, the bot can't work during the night which is when I had scheduled it to run in some rooms which are busy during the day. I thought perhaps the issue was using an old map under the new multi-map firmware update, so deleted the existing map and started all over again with a complete remap, under the new firmware. Unfortunately this hasn't resolved the issue. Please can you look into this? Thanks

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Dear Customer,


    Please send us a picture of the home map interface.

    Use wet cloth to clean the wall sensor and the cliff sensors. Do it multiple times.


    Go to cleaning history and send us a room cleaning map. Please mark the extra area it cleaned.

    You can use the virtual wall or no go zone to avoid the robot mopping on the carpet.

    Besides, you can use zone cleaning to have a try and verify whether it works well.

    And you can change another location to place the dock to give it a shot.


    Could you tell us your device's info?

    Make sure robot is connected to app and go to robot's setting, click "copy all" and then paste all the text (not picture) in your email. See attached picture"info".

    Like0
    djr
    djr05/19/2020      07:00
    @RR_Support:

    Hi - thanks for your prompt reply. Please see maps below showing when the bot couldn't return to the dock after ad-hoc room clean. I gave the robot a full clean as you suggested and this morning it completed a room clean and returned to dock successfully so hopefully the has resolved it.

    I wouldn't need to use no-mop zone or no-go zone if the robot was performing as it should, as these rooms wouldn't be scheduled to be cleaned at night (I remove mop before I goto bed and replace the next evening when it mops kitchen). The robot was working perfectly and I was very please until the latest update. Let's hope the clean sorts out the issue. Al though I have also posted elsewhere regarding not being able to have timer features co-exist with multi-floor map. Hopefully I can get the schedule options back. I can't find 'robot settings' that you mentioned in your reply - please show a screen shot like you have above for cleaning history. If you mean firmware version, then it's 01.07.80. Many thanks.






    Like0
    RR_Support
    RR_SupportStaff Member05/19/2020      11:04
    @djr:

    Hi,


    We are glad to hear that it completed a room clean and returned to dock successfully. You can take more time to monitor its performance.


    It doesn't support the schedule room cleaning feature with Multi-floor map saved mode enabled. Since the vacuum may not locate at the certain floor when cleaning a room with the schedule.

    You can disable the multi-floor maps feature if you need schedule to clean specific room.

    Like0
    djr
    djr05/19/2020      20:24
    @RR_Support:

    Hi - thanks for confirming about schedule and multi-floor co-existing. This would be an obvious enhancement as it seems as if both are key essentials. For now i will disable multi-floor until both can be used together. After giving the robot a full clean yesterday and drying the filer overnight, I had 3 successful ap-room clean-ups today where the robot returned to the dock afterwards. However, unfortunately, after the latest room clean-up the bot just stood still and didn't move for about 10 minutes in full vacuum mode, despite being in the room where the dock is and only 3-4 meters away from the dock. It was only when I noticed i could still hear it that i checked and found it. It had completed the room clean-up but was just on the same spot, hoovering. It wasn't stuck on anything. When I clicked on 'Dock' in the ap it asked if I wanted to end current clean-up, which I did and it returned to the dock with no issues, in a straight line. I'll turn-off multi-floor and see if this makes a difference tomorrow and will post maps if not ... thank you.

    Like0
    Load More >>
  • I received a notification of this new firmware more than a week a go but could not installed it. The downloading is stuck at 15% or 85% though I tried updating the firmware several times. I tried re-installing roborock app and restarting the robot, but no success!

    Another issue is that loading the map is extremely low before, now I cannot load the map. It keeps showing the grey screen with "Loading map..."!

    Like0
    RR_Support
    RR_SupportStaff Member05/26/2020      07:36
    @q_hung:

    Hello, for the firmware issue, try to change the DNS server of the main router to 8.8.8.8/8.8.4.4; and you can connect the vacuum to the mobile hotspot and then reinstall the latest firmware.

    You must get 2 smart phones( A and B) .

    1. Enable phone A's hotspot in phone's setting and create a name and password of hotspot.

    2. Use phone B to install app and try to make robot cleaner connect hotspot sent from phone A.

    For the map loading issue:

    1. Does problem happen at the moment when robot starts from the dock? or it could show map fine before it cleans for some time or some area such as 100 square meters? They are 2 different problems and very important for us to figure out what is wrong.

    2 What is the size of your house? not size already cleaned, but your house's whole size.

    3 Clear cache of app. See attached picture.

    4. Reinstall app to have a try.

    5. Pls use your phone data instead of wifi to see whether map will show up.

    6. Do you have any other Xiaomi's device, like camera, lamp?


    Like0
    q_hung
    q_hung05/27/2020      02:51
    @RR_Support:

    Thanks for your instructions. I tried again and at the 3rd attempt, the new firmware was downloaded and installed successfully to the robot without making any change on the router or using mobile hotspot. Regarding slow map loading, it happened when the robot, router and my phone was in an area of about 1 m2. Anyway, the map is now loaded faster. Again thanks a lot for your support.

    Like0
    RR_Support
    RR_SupportStaff Member05/27/2020      09:37
    @q_hung:

    Hi, we are glad to hear that the firmware has been updated and the map is loaded faster.


    You can take more time to monitor its performance, if you need any further help, be free to let us know.

    Like0

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

djr
Welcome to Roborock Forum