S5 Not Working

My S5 that I purchased last year is not working. When I run it, it just says "Positioning" repeatedly and doesn't go anywhere. I cleaned out the wheels and everything else, but still get the same problem.

The one year warranty just ran out last week. Please help me with this.

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • EDIT: I figured out the problem. There was a large rubber band stuck in the wheel. It's working again.

    RR_SupportStaff Member05/23/2020      08:58

    Dear Customer,

    Thanks for your updates. We are glad to hear that you figured out the problem.

    If you have further question, do not hesitate to contact us.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum