S5 Max Can't Function with Mop Attached

S5 Max Can't Function with Mop Attached

Hi, I've had my S5 Max for a little over a month, and it works great with the vacuum mode; it will go through the whole house in an efficient and logical pattern, it will pick up debris as I would expect, and in general is everything I wanted it to be and do. However, as soon as I attach the mop, which was a major reason I got the S5 Max, it loses its mind. Below is what happens when I attach the mop:

1.) The robot cannot leave the dock on its own, I have to gently nudge the robot backwards physically so it can leave the dock.

2.) The robot just circles around the same area, acting like there is an object there, until it eventually says there is an obstruction. If I continue to hit clean on the app to make it keep going, eventually it may move to a new area to clean but more often than not it keeps freaking out in the same area.

3.) When I send it back to the dock, it makes its way there eventually but cannot get back onto the dock on its own. I have to remove the water tank before it will actually move forward enough to begin charging again.

To give more details about my specific home situation, the majority of the house is vinyl plank hard flooring which is where the dock is. The floors are level and there are no obstacles anywhere near the areas it has issues with. To me, it seems like the water tank is hanging too far down on the back side of the robot to where it cannot handle any sort of incline with would affect getting on and off the dock, though I can't think of a reason why it would freak out over a flat hard floor. Again, none of this is an issue if I simply remove the mop attachment and let it go vacuum only, but I really want the mop part to work as well. I've installed the latest firmware as well, and I already sent an email to support but it's been about 2 weeks and I haven't heard anything back.

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • i'm not an expert but sounds like your S5 max is faulty and you need to have it repaired / replaced under warranty

  • Dear Customer,

    Sorry for the inconvenience caused here.

    Could you send us a video to show the abnormal behavior or sound? We believe a video could help us know what is wrong and give you a solution.

    It is suggested to upload the video online like google drive and send us the video link if the video is large. (remember add our address to list to access video)

    Please put the mopping module in a flat surface and verify whether it is bent. Please send us some pictures as well.

    Could you tell us your device's SN?

    Open the cover of device and take out the dustbin. You will see a bar code on device's bottom(not on dust bin). The SN is under bar code like R0201S82418800.

    If you have already added device to app, you could also check SN on app. See attached picture "info"

    2. Could you send us purchase info?

    Pls send us the purchase link(or screen of product listing), and invoice or receipt (file or screenshot) which shows seller's name, purchasing date and order number.

    Schmuckford05/30/2020      19:28

    Thank you for your reply, here is the info you requested:

    Serial Number: R0512S94802099

    Picture of the mopping attachment on a flat surface (countertop), does not appear to be bent

    Videos via Google Drive:

    Video showing it can't leave the dock on its own: https://tinyurl.com/yb7fe5nl

    Video showing it freaking out and trying to avoid objects that aren't there until it errors out: https://tinyurl.com/y9rqpznx

    As for the invoice, is there a more direct way to get this to you instead of publishing an invoice with my personal info on a publicly viewable forum?

    RR_SupportStaff Member06/01/2020      08:48

    Hi thanks for your reply and info.

    The first link cannot be accessed anymore, could you please re-send it again?

    From the video, it seems that the mopping module prevent the robot from keep walking. Please ensure that the water tank and mopping pad are installed firmly, you will hear a voice prompt.

    Did you use the original mopping cloth? Did you wet it first? Do not use the dry one. If possible, please change another original brand new cloth and verify whether it works.

    Besides, if it is still the same, it is suggested to contact us via email and provide the purchase info. Support@roborock.com

    Schmuckford06/03/2020      16:03

    The first link does not work because the link ends with an underscore (shift - ) which your forums do not accept as a character. Add an underscore to the end of the first link and it will work.

    I used the original mopping cloth but was not aware it should be wet before starting as I assumed that's what the water reservoir was for. I will try that and report back.

    And as I mentioned earlier, I already emailed support about a month ago and I never got a response.

    Load More >>
  • I have this exact issue but with my roborock S5. What was the fix?

    RR_SupportStaff Member10/07/2022      10:47

    Hi, thanks for reaching out. May I confirm with you if you use the model S5 or S5max? Their mopping system is different and the cause may be different.

  • We've started experiencing similar issues with our S5 Max. With the water tank removed the S5 cleans as normal, but once it's fitted it moves around in circles sometimes like it's lost, appears to get stuck in one location.

    Have thoroughly cleaned the wheels, thought it might be spinning in it's own water. Did a factory reset, tried running it in the default factory firmware version before upgrading to the latest version, same results in both versions.

    Does adding the water tank trigger a different run mode?

    What's the fix?

    RR_SupportStaff Member10/15/2022      16:39

    Hi, thanks for your reply. In this case, it's likely that the wheels may lose grip and it may need to be replaced.  Would you please contact us at support@roborock.com(if you are in EU, contact support@roborock-eu.com)so that we can better assist? 


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum