frame

Our 3rd Roborock S6 Exhibits Several Problems

Our 3rd Roborock S6 Exhibits Several Problems

Our brand new Roborock S6 performed excellently for two months before experiencing constant "main brush might be blocked" errors. The second one had mapping problems. The third also has mapping problems, and in addition it keeps getting "main brush might be blocked" errors.

One mapping problem is that it creates pieces of rooms behind walls or in other rooms. Here's an extreme closeup showing a blue room with tiny pieces of it in the next room:


Another mapping problem is that the "Divide" function sometimes only work when you're connected by cellular rather than WiFi. If you try to do it through WiFi then you might get "WiFi connect error" messages, even when right next to the WiFi.

The map of the house is tilted, but the Roborock S6 still makes perfectly horizontal and vertical paths. Here's an image of the tilted map with horizontal and vertical path lines:

We'd just like a Roborock S6 that works or our money back.

Thanks,

--Ted

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • What firmware are you using? I had these map issues (the bits behind the walls) with latest update that allowed multiple floors

    Like0
    RR_Support
    RR_SupportStaff Member06/16/2020      07:46
    @Eli:

    Hi, is it S6?


    You can try the suggestions mentioned above. And you can send us a picture of the home map interface.


    Could you tell where you purchased this robot?

    Like0
  • Hi Ted,


    Thanks for reaching out, and we are sorry for the inconvenience caused here.


    We will do some troubleshooting and try to fix it.

    1. Which app do you use? Roborock app or Mi Home app?
    2. From the pic 1 you provided, the yellow room contains some tiny pieces of the blue room, have you ever tried to divide the room? And could you mark the specific area on the whole map?
    3. As for the "divide" feature, it seems that the wireless connection may not be such good. Clear the cache on the app or reinstall the app to have a try.
    4. For the tilted map, may we suggest you move the dock to another place? The place should be at least 0.5 M wide on left and right side, 1.5 M wide on front side. Many customers solve the issue by changing dock's position.
    5. Beside, you could also try to reset map to create a new map. 
    Like0
    Ted
    Ted06/27/2020      18:54
    @RR_Support:

    Sorry the delay in responding.

    1. I use the Mi Home app.
    2. Yes, I have tried dividing rooms. It's a very sensitive operation. Sometimes it works, sometimes it doesn't. When it doesn't I often suspect it's because some part of what I'm is spatially disconnected.
    3. Interestingly, connecting with cellular instead of WiFi solves the problem where dividing a room caused a WiFi error.
    4. I moved the dock as instructed and obtained a much more orthogonal map.
    5. I have created new maps several times with just this Roborock alone.

    But the showstopper problem still remains. The vac can't make it through the family room rug. It usually halts three times with "main brush errors". There's nothing blocking the brush. The rug is fairly firm, and the original Roborock handled it fine for the first two months.

    Like0
    Ted
    Ted06/27/2020      18:55
    @RR_Support:

    The above reply was originally numbered, but clicking on "POST COMMENT" caused them to go away. Hope it still makes sense.

    Like0
    RR_Support
    RR_SupportStaff Member06/28/2020      07:49
    @Ted:

    Thanks for your reply and info.


    Well noted. Please send us some pictures of the rugs.


    And for the S6 which has the main brush issue, please tell us the device info as pic attached. Then we can forward it to our tech team and ask for some suggestions.


    Like0
    Load More >>
  • See my reply above, it has a picture of the rug and the model info.

    Like0
    RR_Support
    RR_SupportStaff Member07/03/2020      12:14
    @Ted:

    Hello, thanks for your reply.


    We have forwarded to our tech team. And they are working on it. Please kindly wait with patience. Besides, try to clean the main brush or exchange the main brush between different S6 to give it a shot.


    For the tilted map, we suggest you to update the firmware first and then reset the current map and re-map the house again. It will solve the additional blue cube issue also. If not, you can divide room manually to fix it.

    Like0

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Ted
Welcome to Roborock Forum