Map Not Loading Roborock S5

Map Not Loading Roborock S5

Hi. I have a Roborock S5 and an S6 that are cleaning the same single story house. The S5 for some reason gets frozen trying to load its map onto the app. I'm using an apple phone. I've used this same S5 machine successfully for about 1-2 years with mapping without issues. The S6 has no problems cleaning the exact same space and keeping its mapping loading correctly.

The issues seems to happen when the unit gets farther away from the dock. Perhaps when it switches to a wifi range extender (at least that's one theory).

I've tried clearing the cache, deleting the app, reseting wifi … all without success.

The only thing that works is turning off mapping (and losing the map). But then the problem comes right back within a single cleaning anyway so I'm never able to regenerate a map of the whole house.

Something has changed on the software or hardware side last few months for this to happen.

Any help much appreciated.

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hello,

    Thanks for your email.


    1. Does problem happen at the moment when robot starts from the dock? or it could show map fine before it cleans for some time or some area such as 100 square meters? They are 2 different problems and very important for us to figure out what is wrong.

    2. Please send us all info of your robot. See attached picture info.


    3. Take the robot off the charging dock, reboot it by long hold the power button and run the app again to see if it works.

    4. What is the size of your house? not size already cleaned, but your house's whole size.

    5. If you are using Mi Home, tell us which region your Mi Home selects and switch region to the US or Singapore, then re-connect the robot to Mi Home. See attached picture.


    6. Reinstall app to have a try.

    7. Pls use your phone data instead of wifi to see whether map will show up.

    8. Do you have any other Xiaomi's device, like camera, lamp?

    Like0
  • Hi. Sorry for the slow response. Here is the Info from the vacuum:

    Model : roborock.vacuum.s5, Serial number : R0015S82210304, MI ID : 1835830060, Firmware version : 3.5.7_002008, Plug-in version : MI_RZX_40, Wi-Fi name : Pyne Network, IP address : Selected, MAC address : 7C:49:EB:9C:F5:C4, 

    Answers Below:

    1) the problem happens from the very beginning, not after 100 m.

    3) long hold on button power restart did not help

    4 ) Our house is 4500 square feet. Single story. Please note the S5 vacuum worked great for about 18 months before the mapping issue started. We also have a newer S6 that works great with the same house (they are located in opposite ends). This makes me think something has changed with the firmware or something has failed with the hardware on only the s5

    5). I changed from United States to Singapore and this did not help

    6) reinstalling app does not help

    7) changing to cellular data does not help. Also clearing cache does not help.

    8) no cameras or other Xiaomi devices other than the s5 and s6 vacuums.

    Like0
    RR_Support
    RR_SupportStaff Member10/20/2020      10:11
    @robosam:

    The robot doesn't fit big house--larger than 2500-3000 sq.ft. It may not show all house plan on map.

    If it worked well, you can hard reset it to have a try.

    https://youtu.be/bjSVEEgkVn0

    Like0

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

robosam
Welcome to Roborock Forum