My S4 can’t seem to connect to wifi after 3 mths of use?

My S4 can’t seem to connect to wifi after 3 mths of use?

I’ve turn the device on/off a few times and tried reseting wifi many times on the device and I can’t seem to get it connected to wifi? With that I can’t connect it to my phone and the scheduled cleanings don’t happen on time anymore.

I was reading the forum which suggested maybe To change my settings to another region where system might not be down, but I can’t do that either. What’s happening and how can I resolve it?

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hello,

    Which app do you use?

    Could you use another phone to take a video showing how you connect device to app and send us the video? We believe video could help us figure out a solution.

    We suggest you put phone's camera close to phone screen. Besides, also record how wifi indicator(see attached picture) flashes in connection process.

    You could upload video to google drive and share us the link if video file is large.

    Could you tell us your device's SN?

    Open the cover of the device and take out the dustbin. There's a barcode on the bottom of the device (not on dustbin). The SN is under the barcode like R0201S82418800.

    Gina11/20/2020      06:10

    Hi, the serial number is. R0703S02102084. I’ve downloaded both Roborock and Mi Home apps and tried to connect to wifi and both don’t work.

    i don’t have a second phone to video the whole process but safe to say that I followed all the steps of press and hold buttons to reset wifi, and then tried connecting to wifi. All works except until the last bit where it’s says “device unable to connect to network”. Help!!

    RR_SupportStaff Member11/21/2020      07:07

    Try to disable and re-enable wifi function on your cellphone.

    You can change the DNS settings on router to

    Also, ensure that there is no special character in wifi network name and password. If your router supports guest network, you can enable it and give it a shot.

    Reboot the router and robot, then try again.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum