S7 - Black Rug Problem

S7 - Black Rug Problem

Hi All,

I am new here so please excuse me if this has been answered before.

I have a predominantly black rug (picture attached) in my lounge room and the S7 (bought 2 weeks ago) refuses to get onto it and vacuum it.

After some search on the internet it seems like the sensors of the s7 deem the blackness in the rug has a step on stairs or a hole and does not get onto it.

I tried covering up the sensors temporarily and zone cleaned the rug, but that did not work quiet well and it also stuffed up the ground floor map so I had to remap the whole floor.

Has anyone come up with a fix for this yet? I am guessing its the software that is just not recognising the black carpet as a carpet or a rug.

any inputs on this would be greatly appreciated.

Thank you.

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hi, thanks for reaching out. Could you please send us the picture of your rug?

    Besides, please send us a picture to show the bottom of your robot so that we can see if the cliff sensors are covered properly or not.

    Best regards.

    Leo05/18/2022      00:46

    I have the same issue. Video: https://youtu.be/TEIjGOVRXfU


    RR_SupportStaff Member05/19/2022      17:55

    Hi, thanks for reaching out. May I know if you've tried to cover the cliff sensors?


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum