S5 Max cannot connect to Wifi - But it connects to my router

S5 Max cannot connect to Wifi - But it connects to my router

Hello. I haven't used by Roborock S5 Max for a few weeks and when I tried to do it today, it couldn't connect to my Wifi. I thought it was a simple procedure to reconnect, but then the nightmare started.

I tried everything: reset to factory settings, reinstall Roborock App, use a different device, use Xiaomi Mi app, with no luck.

From my router, I see that the Roborock GETS an IP ADDRESS from it, so it does connect to my Wifi and my network. Still, it says cannot connect to Wifi.

I read somewhere that this error might be the robot trying to reach a Roborock server in the Internet. Is it something with my DNS? Which server is it trying to reach? Is it known that some Roborock servers are currently down right now?

PLEASE HELP, I can't use the device I bought.

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hi,

    Thanks for reaching out.

    Our devices don't support 5G HZ wifi but only 2.4G HZ wifi. If it's 2.4G, please try the following:

    1. Make sure the password of your wifi you've input is correct.

    2. Don't use an android tablet, iPad, iPhone 5 or iPhone 5C to connect the robot as there might be a compatible issue.

    3. If there are special characters like !@#$ contains in your wifi name or password, it's suggested to remove them in the router settings.

    4. The robot doesn't support WEP encryption mode. If your wifi is WEP, change it to WPA or WPA2. You could also try to change the wifi channel.

    5. If you understand the router's setting very well, try to change DNS to in the router's settings page.

    6. Reboot your router to see if it works.

    wrows01/02/2022      17:34

    Hello. I already tried all of that. And yes, I also tried to use Google DNS None of that works.

    RR_SupportStaff Member01/10/2022      09:02

    Would you please try the following?

    The robot could connect to a hotspot from a smartphone.

    To connect to a hotspot, you need 2 smart phones (A and B).

    1. Enable phone A's hotspot in phone's setting and create a name and password of hotspot.

    2. Use phone B to install the app and try to connect the robot to the hotspot sent from phone A.

    Forget about the wifi sent from your router in the whole process.

  • S5 Max facing issues with WiFi connectivity? While it connects to your router, there might be a specific concern with its connection to the Dallas Dedicated Server. Troubleshooting this connection may require checking settings or contacting support for a seamless experience.

  • Hi,

    Thanks for your feedback. We are sorry for the trouble you are facing.

    Your question may not be solved in a short answer. We suggest you contact us via email: support@roborock.com. You could attach related pictures or videos in email to help us understand your question.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum