S7+ will not charge

S7+ will not charge

I woke up in the morning and the S7 was off its dock. I manually place it back on the dock and the light on the dock stayed on. I tried to run the robot the next day and it was off. I turned it on and cleaned the house but when it returned to the base it would not dock and didn't empty the bin. I placed it back on the base manually and it still won't charge what it wrong?

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hi,

    Thank you for taking the time to reach out to Customer Support and we are sorry to hear about the trouble you are having with your device.


    1. If there're some stains or rust on the charging contacts on the dock or underneath of the robot, please use a piece of cloth moistened with alcohol solution or an eraser to remove them.


    2. If you have wiped charging contacts, could you send us pictures to show them?

    3. The indicator light on top of the dock should be solid on without the robot and off with the robot placed on it. See attached picture. It's suggested to move the robot a little bit to make the two charging contacts at bottom of the device well attached to the ones on the dock.

    4. Please unplug the charging dock, and leave it there for about 2 minutes. Then please re-plug it and try again.

    Like0
  • Having the same issue. Was fine in the morning and couldn't find dock in the afternoon now it's completely dead.

    Like0
    RR_Support
    RR_SupportStaff Member11/24/2022      09:44
    @Sgathaich:

    Hello,


    Thank you for taking the time to reach out to Customer Support and we are sorry to hear about the trouble you are having with your device.

    Have you checked if the dock is working properly?

    The light in front of the Auto Empty Dock should be on without the robot on it and it should go off with the robot on it.

    Like0

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

kxed
Welcome to Roborock Forum