S7 Maxv Ultra not able to clean mop - Any pointers?

S7 Maxv Ultra not able to clean mop - Any pointers?

I am having a strange issue with my S7 MaxV Ultra with the dock that cleans the mop and empties the dirt bin. After my Vacuum run over cat poo (Did not avoid it for some reason) I cleaned it out and cleaned the mop and now it refuses to dock to clean the mop. If I don't mop the floor it will dock and empty the bin perfectly, as soon as I try and mop it will push up against the dock a few times and then error saying it cannot clean the mop. If I pause the Vac while it is attempting, and push it back manually, it will work if I press down the button for a few seconds but not without manual intervention.

I have tried reseating the mop attachment and bought new mops covers but the issue still exists and I am hoping someone has some pointers as to what I can do to fix this issue.

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • We are sorry to hear that your device did not work well. 

    The issue you faced may not be solved in a short answer. We hope we could work with you to locate the cause and address it. Would you please contact us at support@roborock.com(if you are in EU, contact support@roborock-eu.com)so that we can better assist? 


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum