S5 max - don't charge

S5 max - don't charge


I've a roborock s5max and the device didn't charge. I tried everything, clean the contacts check the base station etc... nothing worked.

I've found that if I remove the battery for a couple of minutes and plug again the battery the device start to charge to full capacity but once get the 100% the device don't charge anymore... I take the advantage of having again the device with battery to do the cleanings but when we gets again low battery I've to do the same procedure.

Anyone with the same issue? Any clue?

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hello, thanks for reaching out.

    Do you mean the battery level doesn't go up? Does it report any error message?

    pedrogbraga03/07/2023      17:02

    No errors reported. The battery level doesn't go up... only when I unplug and plug again the battery cable.

    RR_SupportStaff Member03/16/2023      13:26


    Thanks for the response.

    If the temperature of the battery is too high, this issue is likely to happen. In this case, please put the robot in a cool and well ventilated area for 2 hours to let it cool down, and then try again to see if the issue will persist.

    If the issue persists, would you please reach out to our support team at support@roborock.com(if you are in EU, contact support@roborock-eu.com) so that we can better assist? 


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum