S7 not moping

We just bought a couple months ago. Mop worked great but about a month ago water stopped coming out. Tried unclogging the holes but water still isn't coming out. What should we try next?

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • 1. Make sure the mop cloth is saturated before attaching it to the vibraRise mop cloth mount;

    2. Ensure that the mop cloth is well attached to the VibraRise mop cloth mount;

    3. Ensure that there is no detergent in the water, like Dettol, ethyl alcohol, etc.;

    4. Press the right side of the water tank inwards. See the video in the following link for reference; https://youtu.be/2XJUWzN8o6o

    If the issue persists, would you please reach out to our support team at support@roborock.com(if you are in EU, contact support@roborock-eu.com) so that we can better assist?


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum