Map problems


I'm using a Roborock S6 and it worked really well in our house including the map feature.

Recently though, it seems to get "confused" and screws up the map by overlaying a rotated (or sometimes shifted) version. Attached are two screenshots before and after the problem occurs. (The "rays" going out of the room are normal as there are low windows.)

Any ideas how to fix and/or prevent this?

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • We are sorry for the trouble you are facing.

    Is there mirror on the ground of your house? Robot's laser may reflect on mirror and it will think there is room inside of mirror.

    Have you tried to delete current map and create a new map?

    Btw, it is suggested to contact support via email so that we could reply in time.

    Gottfried01/29/2020      22:23

    There is one room with a mirror but this is at the other end of the house. This creates some artefacts but I'm ok with that.

    The rotating map issue described is in a room without mirrors. When this happens then the robot seems to have lost completely its orientation, e.g., it also won't be able to find its way back to the docking station.

    I tried to delete and recreate the map multiple times but always the same result: it might work once or twice and on then these additional rotated rooms come up again.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum