Roborock S6 refuses to connect to app (but is definitely connected to wifi)

Roborock S6 refuses to connect to app (but is definitely connected to wifi)

Hey all.

I've got my roborock S6 unable to connect to any app.

I follow the instructions etc, and the app has no problems connecting to the robot and sending the wifi details to the robot, except it times out on the third step.

the robot shows up in my 'connected devices' list, and it's definitely connected, so there's no case of 'incorrect wifi settings'

i've rebooted the robot and the router and my phone endlessy (android) and used a different phone as well (iphone) and the robot fails at the same step, despite being given the correct wifi credentials.

it seems like it's the app itself that doesn't want to register the robot being on the network or something along those lines.

this is what i get, and nothing else in the app.

this is the robot connected to my wifi without problems.

i've already disabled ad-protection on my phone etc, but all results in the same.

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hi, thanks for reaching out.

    Could you please use another phone to take a video showing how you connect the device to wifi via the app and send us the video? We believe the video can help us figure out a solution.

    1. We suggest you put the camera close to the phone screen. 

    2. Please also record how the wifi indicator (see attached picture) flashes in the connection process.

    It's suggested to upload the video to google drive and share us the link if video file is large (please don't forget to give us the permission to view the video).

    Eve02/28/2021      02:49

    I have the exact same issue. My robot was working great, then suddenly went offline, and when trying to reconnect I have the same result as this person. I believe something has failed, as I also tried a hard reset and that did not address the issue.

    RR_SupportStaff Member03/02/2021      04:27

    Hi, thanks for your feedback. We noticed you've opened another thread. Could you pls give us feedback under that thread? If possible, please send us a wifi connection process.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum