Restore maps after S5 Max reset

Restore maps after S5 Max reset


Discovered both Home & Power buttons blinking on my S5 Max and no longer accessible via Android app so after doing WiFi rest (didn't help) I had to do full reset of the device. Following full reset, I re-added it to my application but all my maps stored there are now lost. How to get the maps back?

Also, there is a firmware update but it is stuck on 0% for a while and there is no option to restart this process.


You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Hi, thanks for reaching out.

    A factory reset will erase all maps and currently there's no option to restore deleted map. You may need to start a round of full house cleaning to remap the house.

    For the firmware update issue, may I know if it's stuck at downloading or installing?

    AI07/06/2022      21:02

    I've tried a firmware update the following day and it worked. I had to remap whole apartment.

    What is the "Map Saving (Beta) feature in the app for? I always thought that it allows the map and other data to be retrieved?

    RR_SupportStaff Member07/09/2022      12:50

    Hi, thanks for your reply. Once the button is enabled, it means the map will be saved. In the next cleaning session, the robot will use the saved map rather than creating a new map. If it's disabled, the robot will create a new map every time it cleans.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum