Google Home linked, but Roborock doesn't respond to Google Home

Google Home linked, but Roborock doesn't respond to Google Home

I got a roborock s4 a few days ago and it has been working just fine. For the first day, when I linked roborock to Google Home, I could give a voice command to start the robot. Now all of my smart speakers, and the google home app on my phone won't connect with roborock. It says "not responding" when I look at the device in the app on my phone, and the speaker will say "I'm sorry, but I can't reach roborock right now" if I give it a voice command to start the vacuum. The vacuum still works just fine if I use the roborock app itself instead of trying to initiate it through Google Home. I tried unlinking the accounts and the linking it again, but that didn't help and Google Home still says "not responding" when I look at the device in the app.

You can share this article on the community website!

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.

  • Dear Customer,

    Sorry for the trouble caused here.

    May I know what is your google home account?

    And when did you give the voice command?

    Note: You can contact us via email to do further troubleshooting with taken privacy into consideration.

  • I'll email you.

    RR_SupportStaff Member05/25/2020      07:22

    Definitely sure, and I checked our email system and found out that this issue has been resolved. If you need more help in the future, be free to let us know.

  • Do you remember what fixed it? I'm in the same situation. None of my devices can talk to roborock anymore. I had a slight suspicion it might be due to a firmware update(?) but wanted to check with your experience

    RR_SupportStaff Member12/24/2020      14:42

    What is the model number? Which app do you use?

    Does it report any error message if it does not work?

    Andy01/07/2021      00:31

    Hi same issue. S6 pure stopped responding to Google home. I always have to manually go into app and make it Vaccum the home. Please set it right

    RR_SupportStaff Member01/07/2021      11:07

    Try to disable the skill and relink it up to the Google home.

    Load More >>

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to Roborock Forum